Quantcast
Download
(2 Kb)
Download
Updated: 01/20/22 09:25 AM
Pictures
File Info
Compatibility:
Deadlands (7.2.5)
Updated:01/20/22 09:25 AM
Created:11/08/20 01:41 PM
Monthly downloads:49
Total downloads:4,625
Favorites:10
MD5:
Categories:Beta-version AddOns, Miscellaneous
Item Sets Summary Page Percentages
Version: 0.4.1.1
by: tombaa [More]
This was originally a small addon to add a total progress bar to the item sets collection, but with the arrival of the summary page in the Deadlands patch, the addon was updated to just add percentages to the summary page on the progress bars

Find the code on Github at https://github.com/tpjham/CollectionSetBookTotal
v0.4.1.1:
Fixed file names

v0.4.1:
Added missing files, whoops

v0.4:
Removed custom progress bar as it was unnecessary with the summary pages arrival
Added percentages to the summary page progress bars

v0.35.1:
Updated API version to Blackwood DLC

v0.35:
Updated addon to Flames of Ambition DLC
Changed control names to hopefully prevent UI errors with other addons that might have similar controls

v0.3:
Changed the code so there's no saved variables anymore and no dependencies

v0.25:
Fixed an issue where the found items wasn't loading correctly when running the addon for the first time

v0.2:
Fixed up the code a bit

v0.15:
Changed the anchor for the progress bar, hopefully fixing the bar moving on higher resolutions than 1080p
Optional Files (0)


Archived Files (9)
File Name
Version
Size
Uploader
Date
0.4.1.1
1kB
tombaa
01/20/22 05:10 AM
0.4
1kB
tombaa
11/01/21 06:39 PM
0.35.1
2kB
tombaa
06/01/21 08:09 AM
0.35
28kB
tombaa
03/10/21 12:37 AM
0.3
2kB
tombaa
11/11/20 09:45 AM
0.25
3kB
tombaa
11/11/20 03:02 AM
0.2
3kB
tombaa
11/10/20 12:48 PM
0.15
3kB
tombaa
11/10/20 01:23 AM
0.1
3kB
tombaa
11/08/20 01:41 PM


Post A Reply Comment Options
Unread 10/17/22, 03:42 AM  
tseka

Forum posts: 5
File comments: 13
Uploads: 0
Re: Bug with Reconstruction of an Item

Originally Posted by Onigar
Hi, as soon as I choose reconstruct at a transmute station I get an error message and the reconstruct options page is blank.

After disabling this addon I can then reconstruct correctly.

I just had exactly the same problem ...
Report comment to moderator  
Reply With Quote
Unread 03/25/22, 10:16 PM  
Onigar
 
Onigar's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 361
Uploads: 4
Bug with Reconstruction of an Item

Hi, as soon as I choose reconstruct at a transmute station I get an error message and the reconstruct options page is blank.

After disabling this addon I can then reconstruct correctly.

Report comment to moderator  
Reply With Quote
Unread 01/20/22, 05:54 AM  
Baertram
Super Moderator
 
Baertram's Avatar
ESOUI Super Moderator
AddOn Author - Click to view AddOns

Forum posts: 4334
File comments: 5442
Uploads: 74
I couldn't find the addon on Minion?
Your zip file is wrong, it does only contain the txt and lua file but no folder name which equals the txt file name (without.txt): "ItemSetsSummaryPagePercentages"!
Please fix the zip and re upload it.
Last edited by Baertram : 01/20/22 at 05:55 AM.
Report comment to moderator  
Reply With Quote
Unread 01/20/22, 04:51 AM  
tombaa
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 10
Uploads: 1
Originally Posted by MarcusUK
Doesn't work on the Gamepad UI bars. Any chance of an update, please... can't be too hard to add?
Probably isn't hard to add, I can look into it at some point but I haven't really played ESO for a while so I make no promises.

Originally Posted by Kraistlin
I really liked the original addon and like the update too! I couldn't find the addon on Minion? Is it under a different name there, or not available there? Thank you!
Huh, seems to have disappeared from Minion indeed, I'll look into getting it added back
Report comment to moderator  
Reply With Quote
Unread 01/13/22, 07:54 AM  
MarcusUK

Forum posts: 15
File comments: 127
Uploads: 0
Doesn't work on the Gamepad UI bars. Any chance of an update, please... can't be too hard to add?
Report comment to moderator  
Reply With Quote
Unread 01/02/22, 11:25 PM  
Kraistlin

Forum posts: 0
File comments: 12
Uploads: 0
Minion

I really liked the original addon and like the update too! I couldn't find the addon on Minion? Is it under a different name there, or not available there? Thank you!
Report comment to moderator  
Reply With Quote
Unread 03/17/21, 08:18 AM  
tombaa
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 10
Uploads: 1
Originally Posted by tim99
Hi,
another small visual bug


When using it with the Addon "PerfectPixel", it shows the box somewhere in the middle of the screen.


Hi,
unfortunately I don't think I will be looking into that, since it seems that PerfectPixel modifies the window quite a bit.
I've also not been playing ESO actively for a while now, I only just updated the addon for this patch in order to allow people to use it without having to tick "Allow outdated addons", and because the PortToFriendsHouse addon had a control in the code with the same name.

The source code is available on my github though; https://github.com/tpjham/Collection...tBookTotal.lua
for anyone who might want to try and make this compatible with PerfectPixel
Last edited by tombaa : 03/17/21 at 08:19 AM.
Report comment to moderator  
Reply With Quote
Unread 03/11/21, 12:42 AM  
tim99
 
tim99's Avatar
AddOn Author - Click to view AddOns

Forum posts: 21
File comments: 133
Uploads: 12
Hi,
another small visual bug


When using it with the Addon "PerfectPixel", it shows the box somewhere in the middle of the screen.


Report comment to moderator  
Reply With Quote
Unread 03/02/21, 06:15 AM  
@DeadSoon
AddOn Author - Click to view AddOns

Forum posts: 22
File comments: 306
Uploads: 3
Re: Re: Getting UI Error

Originally Posted by @DeadSoon
Originally Posted by manwoodsal
I get an Ui Error when I load this Addon.
This is what come up.

Load[ZO_ComboBox.xml(15, 17)] (Control): Error: Unable to create control [BG]. This control already exists. Either set override="true" to override properties on the existing control or choose a name that is not a duplicate of an existing control.

If I uncheck this addon from the list and reloudui I will not get no error. But only when I run this. I hope this helps.
I also want to report this issue and I found already the cause of this error. This issue appears only if the addon PortToFriendsHouse is also active. You and the other developer just named one particular control the same. Thats the problem.

Because PTF was first, I propose to rename your control
Thanks in advance!
Here just the short information that PTF was updated and the bug should be fixed now.
Last edited by @DeadSoon : 03/02/21 at 06:16 AM.
Report comment to moderator  
Reply With Quote
Unread 03/01/21, 01:22 PM  
@DeadSoon
AddOn Author - Click to view AddOns

Forum posts: 22
File comments: 306
Uploads: 3
Re: Getting UI Error

Originally Posted by manwoodsal
I get an Ui Error when I load this Addon.
This is what come up.

Load[ZO_ComboBox.xml(15, 17)] (Control): Error: Unable to create control [BG]. This control already exists. Either set override="true" to override properties on the existing control or choose a name that is not a duplicate of an existing control.

If I uncheck this addon from the list and reloudui I will not get no error. But only when I run this. I hope this helps.
I also want to report this issue and I found already the cause of this error. This issue appears only if the addon PortToFriendsHouse is also active. You and the other developer just named one particular control the same. Thats the problem.

Because PTF was first, I propose to rename your control
Thanks in advance!
Report comment to moderator  
Reply With Quote
Unread 01/12/21, 10:34 AM  
tim99
 
tim99's Avatar
AddOn Author - Click to view AddOns

Forum posts: 21
File comments: 133
Uploads: 12
Originally Posted by zelenin
I rewrote the addon a little. Made it cleaner, more compact, effective, without LibSets and saved variables.
https://pastebin.com/EnXi7JAD

i used this to replace all within the lua file and it seems to work great so far.

Thanks so much.

The bug with showing a zero value at login or refresh sometimes was the reason i tried it out.



and i still think this should be done by the vanilla ui in the first place as minimum (as so many other things)... but thats a different theme.
Report comment to moderator  
Reply With Quote
Unread 11/18/20, 07:10 PM  
manwoodsal

Forum posts: 0
File comments: 111
Uploads: 0
Getting UI Error

I get an Ui Error when I load this Addon.
This is what come up.

Load[ZO_ComboBox.xml(15, 17)] (Control): Error: Unable to create control [BG]. This control already exists. Either set override="true" to override properties on the existing control or choose a name that is not a duplicate of an existing control.

If I uncheck this addon from the list and reloudui I will not get no error. But only when I run this. I hope this helps.
Report comment to moderator  
Reply With Quote
Unread 11/17/20, 10:50 PM  
Onigar
 
Onigar's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 361
Uploads: 4
Originally Posted by tombaa
Originally Posted by Onigar
Originally Posted by Onigar

Updated addon but sadly no its still the same as before with 0 on initial login.
Updated today to the latest release 0.3 but still the same 0 on initial login.

Im not getting stressed at all, just giving feedback, /relaodui is not so hard to do
I do appreciate the feedback, and I wanted to get it to work out the box for everyone, but I'm not sure what could cause it on your end anymore.
Seems to work just fine for me each time and I can't seem to replicate it, since it should update it once your player is loaded, as per code65536's suggestions

EDIT:
Actually it does happen to me too it seems, I'll have a look at it
Update: over the last few days or so I have been checking at most logins and for me it is now providing the initial value ok. There may still be something there in the code as you have now noticed this 0 effect too but at least for now it seems to be fixed for me
Report comment to moderator  
Reply With Quote
Unread 11/13/20, 01:21 AM  
tombaa
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 10
Uploads: 1
Originally Posted by Onigar
Originally Posted by Onigar

Updated addon but sadly no its still the same as before with 0 on initial login.
Updated today to the latest release 0.3 but still the same 0 on initial login.

Im not getting stressed at all, just giving feedback, /relaodui is not so hard to do
I do appreciate the feedback, and I wanted to get it to work out the box for everyone, but I'm not sure what could cause it on your end anymore.
Seems to work just fine for me each time and I can't seem to replicate it, since it should update it once your player is loaded, as per code65536's suggestions

EDIT:
Actually it does happen to me too it seems, I'll have a look at it
Last edited by tombaa : 11/13/20 at 04:46 AM.
Report comment to moderator  
Reply With Quote
Unread 11/12/20, 02:28 AM  
Onigar
 
Onigar's Avatar
AddOn Author - Click to view AddOns

Forum posts: 3
File comments: 361
Uploads: 4
Originally Posted by Onigar

Updated addon but sadly no its still the same as before with 0 on initial login.
Updated today to the latest release 0.3 but still the same 0 on initial login.

Im not getting stressed at all, just giving feedback, /relaodui is not so hard to do
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: