Quantcast
Download
(51 Kb)
Download
Updated: 01/29/19 08:09 PM
Pictures
File Info
Compatibility:
Murkmire (4.2)
Wolfhunter (4.1)
Summerset (4.0)
Updated:01/29/19 08:09 PM
Created:08/02/18 07:00 PM
Monthly downloads:170
Total downloads:839
Favorites:3
MD5:
4.2
STFU Elemental Weapons
Version: 1.6
by: Jodynn [More]
Try to reduce the Painful sound of imbue/crushing/elemental weapon.

Also, has an option to show your Spell Orb Count

Registered New Skills
You can now register new skills if you want
- /stfuregister
This will initiate a register, the next skill you use will register as a skill to be muffled.
- /stfuunregister
This will initiate an unregister, the next skill, if you have it registered, will be unregistered



Donation Link


https://www.paypal.com/pools/c/8a80aoQpa4
V 1.6 - Ability to register any other main skill

V 1.4 - Requires LibMediaProvider and LibAddonMenu now

V 1.3 - Remove the debugging, @[email protected], and also updated version numbers

V 1.2 - Fixed a bug with font for spell orb and use ability id instead of name so that it will be language independent.

V 1.1 - Add spell orb text indicating how many you have up
Archived Files (6)
File Name
Version
Size
Uploader
Date
1.5
51kB
Jodynn
10/22/18 06:25 PM
1.5
51kB
Jodynn
09/20/18 07:27 AM
1.4
48kB
Jodynn
09/02/18 10:31 AM
1.2
48kB
Jodynn
08/31/18 10:58 AM
1.1
48kB
Jodynn
08/04/18 11:52 PM
1
48kB
08/02/18 07:00 PM


Post A Reply Comment Options
Unread 01/03/19, 10:17 AM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 82
Uploads: 9
Re: biting jabs

Originally Posted by morningstar999
Can you make one for biting jabs?
I'll do one better, I'll give you a choice of skills to do it for .

Assuming that's easy, it should be.
Report comment to moderator  
Reply With Quote
Unread 12/31/18, 04:02 PM  
morningstar999

Forum posts: 0
File comments: 1
Uploads: 0
biting jabs

Can you make one for biting jabs?
Report comment to moderator  
Reply With Quote
Unread 09/20/18, 02:35 PM  
Andrea

Forum posts: 0
File comments: 13
Uploads: 0
Originally Posted by Jodynn
Originally Posted by Andrea
Originally Posted by Jodynn
Originally Posted by Jodynn
Originally Posted by Andrea
Just installed the app, also downloaded LibMediaProvider but i am getting this error



I will lool into it, sorry for that!!
try 1.5 out
You mean this ?
LibMediaProvider 1.0 r5 - 07/17/14 08:49 PM

I didn't understand correctly what to do (I downloaded all through minion client)
nah just update elemental weapon, it was my fault, I'm not hosting the lib
Nice, it works now, thanks !
Report comment to moderator  
Reply With Quote
Unread 09/20/18, 01:40 PM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 82
Uploads: 9
Originally Posted by Andrea
Originally Posted by Jodynn
Originally Posted by Jodynn
Originally Posted by Andrea
Just installed the app, also downloaded LibMediaProvider but i am getting this error



I will lool into it, sorry for that!!
try 1.5 out
You mean this ?
LibMediaProvider 1.0 r5 - 07/17/14 08:49 PM

I didn't understand correctly what to do (I downloaded all through minion client)
nah just update elemental weapon, it was my fault, I'm not hosting the lib
Report comment to moderator  
Reply With Quote
Unread 09/20/18, 09:50 AM  
Andrea

Forum posts: 0
File comments: 13
Uploads: 0
Originally Posted by Jodynn
Originally Posted by Jodynn
Originally Posted by Andrea
Just installed the app, also downloaded LibMediaProvider but i am getting this error



I will lool into it, sorry for that!!
try 1.5 out
You mean this ?
LibMediaProvider 1.0 r5 - 07/17/14 08:49 PM

I didn't understand correctly what to do (I downloaded all through minion client)
Last edited by Andrea : 09/20/18 at 10:01 AM.
Report comment to moderator  
Reply With Quote
Unread 09/20/18, 07:27 AM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 82
Uploads: 9
Originally Posted by Jodynn
Originally Posted by Andrea
Just installed the app, also downloaded LibMediaProvider but i am getting this error



I will lool into it, sorry for that!!
try 1.5 out
Report comment to moderator  
Reply With Quote
Unread 09/20/18, 06:44 AM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 82
Uploads: 9
Originally Posted by Andrea
Just installed the app, also downloaded LibMediaProvider but i am getting this error



I will lool into it, sorry for that!!
Report comment to moderator  
Reply With Quote
Unread 09/20/18, 02:54 AM  
Andrea

Forum posts: 0
File comments: 13
Uploads: 0
Just installed the app, also downloaded LibMediaProvider but i am getting this error


user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:1: Cannot find a library instance of "LibMediaProvider-1.0".
stack traceback:
user:/AddOns/DeathReport/libs/LibStub/LibStub.lua:29: in function 'LibStub:GetLibrary'
|caaaaaa<Locals> self = tbl, major = "LibMediaProvider-1.0" </Locals>|r
user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:1: in function '(main chunk)'
Report comment to moderator  
Reply With Quote
Unread 09/07/18, 05:29 AM  
Iliana
 
Iliana's Avatar

Forum posts: 0
File comments: 9
Uploads: 0
Originally Posted by Jodynn
Thank you so much for your continued feedback and patience!!
You are more than welcome!
Report comment to moderator  
Reply With Quote
Unread 09/06/18, 10:08 AM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 82
Uploads: 9
Originally Posted by Iliana
Okay. Me again. It is still working as it should, but I get this now



Not sure what it means or how it will affect anything, just thought I would share it
@[email protected] ohmygoodness, that's my fault, I need to require that library in the mainfest so that it tells you you must install the library to use that addon so whenever it tries to access that library it won't give you that error.

Currently at work, but! if you install the addon LibMediaProvider it'll fix the issue, it's a library that the font or sound depend on ( I don't remember which I think font though ).

Thank you so much for your continued feedback and patience!!
Report comment to moderator  
Reply With Quote
Unread 09/06/18, 09:58 AM  
Iliana
 
Iliana's Avatar

Forum posts: 0
File comments: 9
Uploads: 0
Okay. Me again. It is still working as it should, but I get this now



Not sure what it means or how it will affect anything, just thought I would share it
Last edited by Iliana : 09/06/18 at 09:59 AM.
Report comment to moderator  
Reply With Quote
Unread 09/02/18, 10:26 AM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 82
Uploads: 9
X.X

Oh my goodness I forgot to take that out haha, thank you so much, let me fix that super quick X.X

Originally Posted by Iliana
It works great now!
Only thing I get now in chat is this:



I guess it's the debugging?

Edit:

Actually, as long as the addon is active I get that for every skill I cast.
Report comment to moderator  
Reply With Quote
Unread 09/01/18, 03:45 AM  
Iliana
 
Iliana's Avatar

Forum posts: 0
File comments: 9
Uploads: 0
It works great now!
Only thing I get now in chat is this:



I guess it's the debugging?

Edit:

Actually, as long as the addon is active I get that for every skill I cast.
Last edited by Iliana : 09/01/18 at 04:04 AM.
Report comment to moderator  
Reply With Quote
Unread 08/31/18, 10:45 AM  
Jodynn
 
Jodynn's Avatar
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 82
Uploads: 9
Sorry!

Sorry it took me so long to respond!

I have a fix pending, V1.2 local testing worked but let me know if it doesn't!

Thank you!
Last edited by Jodynn : 08/31/18 at 10:58 AM.
Report comment to moderator  
Reply With Quote
Unread 08/21/18, 12:09 PM  
Iliana
 
Iliana's Avatar

Forum posts: 0
File comments: 9
Uploads: 0
God, this would be such an amazing addon, if it would still work!

But when I want to use it, it returns these errors:

user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:297: attempt to index a nil value
stack traceback:
user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:297: in function 'STFU.createSettingsPage'
<Locals> LAM = tbl, dropFontStyle = tbl, panelData = tbl </Locals>
user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:39: in function 'STFU.OnInitialized'
<Locals> eventCode = 65536, addOnName = "STFUElementalWeapon" </Locals>

---

user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:79: operator + is not supported for nil + number
stack traceback:
user:/AddOns/STFUElementalWeapon/STFUElementalWeapon.lua:79: in function 'STFU.gimmeSoundBack'
Last edited by Iliana : 08/21/18 at 12:10 PM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.