Quantcast
Download
(37 Kb)
Download
Updated: 03/02/20 04:44 AM
Addon for:
No, thank you!.
Compatibility:
Harrowstorm (5.3.4)
Updated:03/02/20 04:44 AM
Created:10/21/19 07:20 PM
Monthly downloads:1,076
Total downloads:8,575
Favorites:51
MD5:
5.3.4
No, thank you! - Harrowstorm  Popular! (More than 5000 hits)
Version: 10.4b
by: uta.karas [More]
This is an updated version of No, thank you! for Harrowstorm.

All libraries are removed from the addon so you need install them individually if not yet.
v10.4b
- removed dependency of LibStub

v10.4a
- fixed "Don't warn when trying to equip a bindable item" option didn't work by D&D
- fixed "Disable Chat autocompletion" option didn't work
- added Dragonguard Sanctum Wayshrine to Capital Wayshrines on world map

v10.4
- compatible with update25 (Harrowstorm)
- moved the LibAnnyoingUpdateNotificationInGame library from DependsOn to OptionalDependsOn
- fixed an error occurred when D&D a BoE gear into equipment area while "Don't warn when trying to equip a bindable item" on
> it will show the warning by D&D, means this option doesn't work because of unable to ignore the warn on this situation.
> still this warning is ignorable when double clicking a BoE gear for equipping.
- "Disable Chat autocompletion" option is temporarily disabled on update25 environment because of this feature occuring errors on pts
> it will be developped in another way when new API document will be released.

v10.3b
- fixed "chat message" option for blocking AVA messages didn't work
- fixed "chat message" option for blocking message "Lorebook Discovered" didn't work
- fixed "chat message" option for blocking message "Ability progressed to Rank X" didn't work

v10.3a
- fixed "Hide" option for Unowned Houses didn't work

v10.3
- compatible with update24 (Dragonhold)
- removed all libraries
- added recent Capital Wayshrines (Lilmoth, Rimmen and Senchal) on world map
- fixed some arenas (DragonStar and Maelstrom) were not hidden on world map as dungeons

before
see No thank you#ChangeLog
Archived Files (5)
File Name
Version
Size
Uploader
Date
10.4a
37kB
uta.karas
02/26/20 08:53 PM
10.4
37kB
uta.karas
02/07/20 06:51 PM
10.3b
37kB
uta.karas
11/23/19 06:57 PM
10.3a
37kB
uta.karas
11/11/19 03:43 AM
10.3
37kB
uta.karas
10/21/19 07:20 PM


Post A Reply Comment Options
Unread 10/21/19, 07:59 PM  
amber1019
Addon Addict
 
amber1019's Avatar
Premium Member

Forum posts: 92
File comments: 413
Uploads: 0
Thank you!
Report comment to moderator  
Reply With Quote
Unread 10/21/19, 11:24 PM  
Keresthus

Forum posts: 2
File comments: 17
Uploads: 0
You've saved my life
Report comment to moderator  
Reply With Quote
Unread 10/22/19, 03:32 AM  
Marazota

Forum posts: 159
File comments: 1188
Uploads: 0
pls add option to hide unowned houses not only on tamriel map but on zone maps too



Last edited by Marazota : 10/22/19 at 03:34 AM.
Report comment to moderator  
Reply With Quote
Unread 10/23/19, 05:00 PM  
771Zuel

Forum posts: 2
File comments: 26
Uploads: 0
Thank you so much for taking this over. Every patch I get worried it will stop working.
Report comment to moderator  
Reply With Quote
Unread 10/26/19, 01:40 PM  
amber1019
Addon Addict
 
amber1019's Avatar
Premium Member

Forum posts: 92
File comments: 413
Uploads: 0
Exclamation Skills Option Not Working

Under Skills, the "Block message 'ability progressed to rank X'" doesn't seem to be working.
At least, it doesn't work when changed to "chat".
Could you please look into this?
Report comment to moderator  
Reply With Quote
Unread 10/29/19, 06:28 PM  
amber1019
Addon Addict
 
amber1019's Avatar
Premium Member

Forum posts: 92
File comments: 413
Uploads: 0
Exclamation Remove Unnecessary Library Dependency, Please

Please update the txt file.
It's no longer loading the "annoying update" library for whatever reason (the author made an update and changed the name, kind of???), so it shows as a dependency that is missing.

It's really not a necessary library and is called "annoying" for a reason. Ugh. You can simply delete that library from the txt file's "DependsOn". (It's what I did.)
Report comment to moderator  
Reply With Quote
Unread 11/02/19, 04:31 PM  
uta.karas
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 35
Uploads: 3
ok calm down plz.

this is just a patch for fixing critical errors caused by game update.

i had no thought of developing this addon, so left the working part as it was.
Report comment to moderator  
Reply With Quote
Unread 11/05/19, 02:58 PM  
tgrippa

Forum posts: 0
File comments: 5
Uploads: 0
Thank you

Great update, thanks for picking this up.
Report comment to moderator  
Reply With Quote
Unread 11/11/19, 10:21 AM  
amber1019
Addon Addict
 
amber1019's Avatar
Premium Member

Forum posts: 92
File comments: 413
Uploads: 0
Exclamation Please Remove LAUNIG Dependency

Seriously, this does not work with the newest version of LibAnnoyingUpdateNotificationInGame.
This version of No, Thank You! shows a dependency is missing now.

Do us all a favor and remove it from the txt file.

It should look like this:
## DependsOn: LibAddonMenu-2.0 LibStub LibNotification
Report comment to moderator  
Reply With Quote
Unread 11/17/19, 03:31 AM  
uta.karas
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 35
Uploads: 3
Re: Please Remove LAUNIG Dependency

Originally Posted by amber1019
Seriously, this does not work with the newest version of LibAnnoyingUpdateNotificationInGame.
This version of No, Thank You! shows a dependency is missing now.
i already said no for this request.

again, this is just a patch for fixing critical errors caused by game update.

i had no thought of developing this addon, so left the working part as it was.
Report comment to moderator  
Reply With Quote
Unread 11/17/19, 04:24 AM  
amber1019
Addon Addict
 
amber1019's Avatar
Premium Member

Forum posts: 92
File comments: 413
Uploads: 0
Re: Re: Please Remove LAUNIG Dependency

Originally Posted by uta.karas
Originally Posted by amber1019
Seriously, this does not work with the newest version of LibAnnoyingUpdateNotificationInGame.
This version of No, Thank You! shows a dependency is missing now.
i already said no for this request.

again, this is just a patch for fixing critical errors caused by game update.

i had no thought of developing this addon, so left the working part as it was.
I don't think you understand.
If we have the latest version of the library LAUNIG installed (most likely due to other addons requiring it installed as a standalone library), your version of "No, Thank You!" will not work. It will say a dependency is missing. Because the name of the library (how it's meant to be called in the txt file) has changed.

I'm just trying to look out for other users. It's an EXTREMELY simple request. If you'd like, I can do it for you and send you a link to the zip file including the edited txt file. There's no good reason not to remove the need for that library. It's literally deleting a few letters and saving the document. Would you rather I take over this addon, and leave you as co-suthor?

But okay. I don't understand. But okay.
I can do it for myself with no problems. It's others I'm concerned about.
Report comment to moderator  
Reply With Quote
Unread 11/17/19, 05:31 AM  
uta.karas
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 35
Uploads: 3
Re: Re: Re: Please Remove LAUNIG Dependency

Originally Posted by amber1019
Originally Posted by uta.karas
Originally Posted by amber1019
Seriously, this does not work with the newest version of LibAnnoyingUpdateNotificationInGame.
This version of No, Thank You! shows a dependency is missing now.
i already said no for this request.

again, this is just a patch for fixing critical errors caused by game update.

i had no thought of developing this addon, so left the working part as it was.
I don't think you understand.
If we have the latest version of the library LAUNIG installed (most likely due to other addons requiring it installed as a standalone library), your version of "No, Thank You!" will not work. It will say a dependency is missing. Because the name of the library (how it's meant to be called in the txt file) has changed.

I'm just trying to look out for other users. It's an EXTREMELY simple request. If you'd like, I can do it for you and send you a link to the zip file including the edited txt file. There's no good reason not to remove the need for that library. It's literally deleting a few letters and saving the document. Would you rather I take over this addon, and leave you as co-suthor?

But okay. I don't understand. But okay.
I can do it for myself with no problems. It's others I'm concerned about.
fmm, weird.
I installed that lib individually from minion.
the version is 7 and minion says it's latest.
and there is no problem with dependency for this addon.

Are there anyone have same problem?
Report comment to moderator  
Reply With Quote
Unread 11/24/19, 07:23 AM  
Keresthus

Forum posts: 2
File comments: 17
Uploads: 0
I have other addons installed that provide included versions of LAUNIG, and hadn't had it installed separately. To test amber1019's issue, I installed the separate version. No problems. However, until I installed LAUNIG separately and after I removed that version again, I've been getting this message every time I log in:
[05:19:55] The library 'Launig' was already loaded!
Report comment to moderator  
Reply With Quote
Unread 11/24/19, 10:23 PM  
arps

Forum posts: 0
File comments: 5
Uploads: 0
All of my addon setting menus are blank? versions 10.3b

fixed: still had my old saved variables from previous addon.
Last edited by arps : 11/26/19 at 03:06 PM.
Report comment to moderator  
Reply With Quote
Unread 12/08/19, 07:04 PM  
tawniey

Forum posts: 5
File comments: 10
Uploads: 0
AnnoyingUpdates Lib "Missing" but not...

This is honestly driving me a bit batty. "Annoying" is truly the best preface for this library name. I can't even use "No, thank you! - Dragonhold" because it won't recognize that I've got the library installed, even though I've installed it manually, through minion, renamed the file to match what the dialogue box says... I've done everything I can think of and still nothing. This is absurd. Is there ANY hope for a fix for this? Why do we even need this library??

https://i.imgur.com/oNVi14i.png
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: