Quantcast
Download
(3 Kb)
Download
Updated: 05/31/19 01:35 PM
Addon for:
Advanced Filters.
Pictures
File Info
Compatibility:
Elsweyr (5.0.5)
Wrathstone (4.3)
Murkmire (4.2)
Wolfhunter (4.1)
Summerset (4.0)
Dragon Bones (3.3)
Clockwork City (3.2)
Horns of the Reach (3.1)
Morrowind (3.0)
Homestead (2.7)
One Tamriel (2.6)
Updated:05/31/19 01:35 PM
Created:01/07/17 03:40 PM
Monthly downloads:377
Total downloads:8,003
Favorites:21
MD5:
5.0.5
Advanced Filters - FCO Item trait filter plugin  Popular! (More than 5000 hits)
Version: 2.3
by: Baertram [More]
Item trait filter plugin

This PLUGIN depends on the following ADDONs:
Advanced Filters Updated (old name: BETA)

This is a filter PLUGIN for the dynamic filters of the "Advanced Filters Updated" addon.
It is not working together with the outdated AdvancedFilters addon!
It will be able to filter your items (weapons, armor, jewelry) in your inventories by all the different item traits that the game provides.

Please use filter dropdown box of AdvancedFilters, located at the top right edge inside your inventories, to select the different filters.
Right click the filter box to invert a filter or to show all items again (reset filters).
-2.4-
Fixed armor trait show again
Added missing jewelry traits

-2.2-
Raised API, fixed armor trait show again

-2.1-
Raised API, made compatible with actual AdvancedFilters version

-2.0-
Raised API, removed unneeded itemtype that will be buggy with next game patch 3.1

-1.9-
Sorted the entries alphabetically

-1.8-
Api raise to Homestead
Archived Files (6)
File Name
Version
Size
Uploader
Date
2.2
3kB
Baertram
05/27/19 09:59 PM
2.1
3kB
Baertram
08/05/18 05:45 PM
2.0
3kB
Baertram
07/16/17 01:54 PM
1.9
3kB
Baertram
04/20/17 01:29 PM
1.8
3kB
Baertram
02/06/17 02:27 PM
0.0.1
3kB
01/07/17 03:40 PM


Post A Reply Comment Options
Unread 06/18/19, 04:28 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2205
File comments: 2427
Uploads: 57
Hey there,

about your post:
Originally Posted by SteveCampsOut
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
I'm not able to rebuild this error so far and there are other users who told in the comments and my guilds that the addon and plugin are working fine for them.

Please logout, delete both, the plugin folder and the AdvancedFilters folder,also remove the AdvancedFilters.lua from the SavedVariables folder please!

And afterwards reinstall both from the links here (manually as Minion might **** things up sometimes):
https://www.esoui.com/downloads/info...dNameBETA.html

https://www.esoui.com/downloads/info...terplugin.html

Start the game and ONLY (during character selection screen!) enable this addon + needed libraries, and the plugin on one character. Then login with this char and tell me if the error still happens.
If so please write in detail what to do to rebuild/get this error.

If it does not happen it was most probably a wrong update or some other addon causing it and you need to check how to rebuild th error, having which addons and plugins enabled please.

Many thanks. Hope this will fix it for you though!

Baertram



Originally Posted by SteveCampsOut
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
Report comment to moderator  
Reply With Quote
Unread 06/03/19, 05:29 PM  
fgoron2000

Forum posts: 0
File comments: 111
Uploads: 0
Originally Posted by Baertram
Not that easy, there is changed a lot. I hope I'm able to get the error too, so I can test it.

Originally Posted by SteveCampsOut
Originally Posted by Baertram
Hmm, I wonder why I did not get this error yesterday. Sometimes I hate lua.
Did a quick check of the code lines mentioned in the lua error and everything looks OK for me...
When exactly did you get the error, and at what panel (inventory, crafting smiting, crafting jewelry, junk,...?)

Sorry, will be fixed in 2 weeks then

Originally Posted by SteveCampsOut
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
I was getting it at Login. Dropping back to the previous version it went away so to find the error I'd say look at what you changed between 2_2 and 2_3.
I've been offline for a few days so I only had a chance to try this addon today, but the new version worked fine for me, the menus were listed at the crafting stations as expected, and I got no lua errors.
Report comment to moderator  
Reply With Quote
Unread 06/01/19, 05:11 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2205
File comments: 2427
Uploads: 57
Not that easy, there is changed a lot. I hope I'm able to get the error too, so I can test it.

Originally Posted by SteveCampsOut
Originally Posted by Baertram
Hmm, I wonder why I did not get this error yesterday. Sometimes I hate lua.
Did a quick check of the code lines mentioned in the lua error and everything looks OK for me...
When exactly did you get the error, and at what panel (inventory, crafting smiting, crafting jewelry, junk,...?)

Sorry, will be fixed in 2 weeks then

Originally Posted by SteveCampsOut
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
I was getting it at Login. Dropping back to the previous version it went away so to find the error I'd say look at what you changed between 2_2 and 2_3.
Report comment to moderator  
Reply With Quote
Unread 06/01/19, 02:44 AM  
SteveCampsOut
 
SteveCampsOut's Avatar

Forum posts: 23
File comments: 305
Uploads: 0
Originally Posted by Baertram
Hmm, I wonder why I did not get this error yesterday. Sometimes I hate lua.
Did a quick check of the code lines mentioned in the lua error and everything looks OK for me...
When exactly did you get the error, and at what panel (inventory, crafting smiting, crafting jewelry, junk,...?)

Sorry, will be fixed in 2 weeks then

Originally Posted by SteveCampsOut
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
I was getting it at Login. Dropping back to the previous version it went away so to find the error I'd say look at what you changed between 2_2 and 2_3.
Last edited by SteveCampsOut : 06/01/19 at 02:45 AM.
Report comment to moderator  
Reply With Quote
Unread 06/01/19, 01:25 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2205
File comments: 2427
Uploads: 57
Hmm, I wonder why I did not get this error yesterday. Sometimes I hate lua.
Did a quick check of the code lines mentioned in the lua error and everything looks OK for me...
When exactly did you get the error, and at what panel (inventory, crafting smiting, crafting jewelry, junk,...?)

Sorry, will be fixed in 2 weeks then

Originally Posted by SteveCampsOut
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
Last edited by Baertram : 06/01/19 at 01:33 AM.
Report comment to moderator  
Reply With Quote
Unread 05/31/19, 06:39 PM  
SteveCampsOut
 
SteveCampsOut's Avatar

Forum posts: 23
File comments: 305
Uploads: 0
Originally Posted by Baertram
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.

Well today this happened after the new update:



Reverted to previous Update for now....
Last edited by SteveCampsOut : 05/31/19 at 06:44 PM.
Report comment to moderator  
Reply With Quote
Unread 05/31/19, 01:34 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2205
File comments: 2427
Uploads: 57
Found the problem and you are lucky, last day before take off :-)
Hope it is (really) fixed now.
Report comment to moderator  
Reply With Quote
Unread 05/29/19, 06:20 PM  
fgoron2000

Forum posts: 0
File comments: 111
Uploads: 0
Originally Posted by Baertram
Okay, sorry then. I'll need to dig in further into the addon code.
Fixing the missing jewelry traits as well I guess is a good idea.
But I'm on vacations soon so don't expect anything in the next weeks

Originally Posted by fgoron2000
Originally Posted by fgoron2000
Originally Posted by Baertram
Originally Posted by fgoron2000
Hi, after I recently switched from the original Advanced Filters to your newer version of Advanced Filters, I had a brief issue with the Sets plugin, and then you promptly resolved it for me. Now, I'm noticing that the dropdown for the FCO Item Trait plugin is appearing at crafting stations but only for Weapons, not for any Armor. It does appear for Armor in my own and my bank's inventories however. I checked for any missing LIB's but the only dependency indicated was Advanced Filters. Any thoughts?
Updated it, there were some filterPanels excluded by accident. Hope it works now.
thanks very much for your prompt response...I'll be checking it out a bit later today & let you know...
understood, thanks again, and let me know if i can provide any info for you when you're back from vacay


I'm afraid that it didn't resolve the issue. I also uninstalled and reinstalled just in case, but no change. Is there any other info I can provide you that could help to resolve it?
Report comment to moderator  
Reply With Quote
Unread 05/29/19, 12:29 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2205
File comments: 2427
Uploads: 57
Okay, sorry then. I'll need to dig in further into the addon code.
Fixing the missing jewelry traits as well I guess is a good idea.
But I'm on vacations soon so don't expect anything in the next weeks

Originally Posted by fgoron2000
Originally Posted by fgoron2000
Originally Posted by Baertram
Originally Posted by fgoron2000
Hi, after I recently switched from the original Advanced Filters to your newer version of Advanced Filters, I had a brief issue with the Sets plugin, and then you promptly resolved it for me. Now, I'm noticing that the dropdown for the FCO Item Trait plugin is appearing at crafting stations but only for Weapons, not for any Armor. It does appear for Armor in my own and my bank's inventories however. I checked for any missing LIB's but the only dependency indicated was Advanced Filters. Any thoughts?
Updated it, there were some filterPanels excluded by accident. Hope it works now.
thanks very much for your prompt response...I'll be checking it out a bit later today & let you know...
I'm afraid that it didn't resolve the issue. I also uninstalled and reinstalled just in case, but no change. Is there any other info I can provide you that could help to resolve it?
Report comment to moderator  
Reply With Quote
Unread 05/28/19, 09:58 PM  
fgoron2000

Forum posts: 0
File comments: 111
Uploads: 0
Originally Posted by fgoron2000
Originally Posted by Baertram
Originally Posted by fgoron2000
Hi, after I recently switched from the original Advanced Filters to your newer version of Advanced Filters, I had a brief issue with the Sets plugin, and then you promptly resolved it for me. Now, I'm noticing that the dropdown for the FCO Item Trait plugin is appearing at crafting stations but only for Weapons, not for any Armor. It does appear for Armor in my own and my bank's inventories however. I checked for any missing LIB's but the only dependency indicated was Advanced Filters. Any thoughts?
Updated it, there were some filterPanels excluded by accident. Hope it works now.
thanks very much for your prompt response...I'll be checking it out a bit later today & let you know...
I'm afraid that it didn't resolve the issue. I also uninstalled and reinstalled just in case, but no change. Is there any other info I can provide you that could help to resolve it?
Report comment to moderator  
Reply With Quote
Unread 05/28/19, 09:44 AM  
fgoron2000

Forum posts: 0
File comments: 111
Uploads: 0
Originally Posted by Baertram
Originally Posted by fgoron2000
Hi, after I recently switched from the original Advanced Filters to your newer version of Advanced Filters, I had a brief issue with the Sets plugin, and then you promptly resolved it for me. Now, I'm noticing that the dropdown for the FCO Item Trait plugin is appearing at crafting stations but only for Weapons, not for any Armor. It does appear for Armor in my own and my bank's inventories however. I checked for any missing LIB's but the only dependency indicated was Advanced Filters. Any thoughts?
Updated it, there were some filterPanels excluded by accident. Hope it works now.
thanks very much for your prompt response...I'll be checking it out a bit later today & let you know...
Report comment to moderator  
Reply With Quote
Unread 05/28/19, 01:12 AM  
Snakefish

Forum posts: 0
File comments: 108
Uploads: 0
Question 4.1

Update, but still Wolfhunter 4.1 support?
Last edited by Snakefish : 05/28/19 at 07:19 AM.
Report comment to moderator  
Reply With Quote
Unread 05/27/19, 10:04 PM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2205
File comments: 2427
Uploads: 57
Originally Posted by fgoron2000
Hi, after I recently switched from the original Advanced Filters to your newer version of Advanced Filters, I had a brief issue with the Sets plugin, and then you promptly resolved it for me. Now, I'm noticing that the dropdown for the FCO Item Trait plugin is appearing at crafting stations but only for Weapons, not for any Armor. It does appear for Armor in my own and my bank's inventories however. I checked for any missing LIB's but the only dependency indicated was Advanced Filters. Any thoughts?
Updated it, there were some filterPanels excluded by accident. Hope it works now.
Report comment to moderator  
Reply With Quote
Unread 05/27/19, 08:45 AM  
fgoron2000

Forum posts: 0
File comments: 111
Uploads: 0
Hi, after I recently switched from the original Advanced Filters to your newer version of Advanced Filters, I had a brief issue with the Sets plugin, and then you promptly resolved it for me. Now, I'm noticing that the dropdown for the FCO Item Trait plugin is appearing at crafting stations but only for Weapons, not for any Armor. It does appear for Armor in my own and my bank's inventories however. I checked for any missing LIB's but the only dependency indicated was Advanced Filters. Any thoughts?
Report comment to moderator  
Reply With Quote
Unread 08/01/18, 03:06 AM  
Baertram
 
Baertram's Avatar
AddOn Author - Click to view AddOns

Forum posts: 2205
File comments: 2427
Uploads: 57
Yes, I did not find the time to update the plugins officially after AdvancedFilters got updated to support craft stations (officially) but it's updated meanwhile.
Last edited by Baertram : 05/27/19 at 09:44 PM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: