Quantcast
 
Results: 704Comments by: sirinsidiator
File: LibAddonMenu02/08/19
Will the next version no longer rel...
Posted By: sirinsidiator
Will the next version no longer rely on LibStub? Many addons are only requiring LibStub for LAM usage at this point. Changing LAM to no longer use LibStub would require every addon that depends on it to be changed, since it would no longer be accessed via LibStub("LibAddonMenu-2.0"). Not something I'll do on such short notice and wi...
File: LibAddonMenu02/05/19
It is neither an inconsistency nor...
Posted By: sirinsidiator
It is neither an inconsistency nor a bug. This is the intended behavior. I repeat once again: The manifest file too is part of what the AddOnVersion is describing. When you change the manifest, you have to increment the version, otherwise you have two variations of the "code" with the same version number. The APIVersion directive...
File: LibAddonMenu02/05/19
What you describe is not a bug in t...
Posted By: sirinsidiator
What you describe is not a bug in the game. When you have duplicate addons in your folder and change ANYTHING in ANY file that is loaded by the game, you need to increment the AddOnVersion. Otherwise you have two different versions of the addon code with the same version number. The APIVersion is not a tie breaker - it is completely...
File: AwesomeGuildStore02/01/19
Re: minion downloading zip to Addons folder but not unpacking
Posted By: sirinsidiator
minion downloading zip to Addons folder but not unpacking With the last few updates I've found that minion is downloading the zip file to the Addons folder but not unpacking the zip file into the AGS folder. A manual unzip works fine. Just a heads up in case others are having the same issue. That's strange. Could you please pm...
File: ChatLogger01/30/19
is this still functioning? when i...
Posted By: sirinsidiator
is this still functioning? when i click on the exe file in viewer folder all i get is a blank gray window that pops up, nothing in it It should still work, but you may need to use an older version of nw.js. The last version I tested it with was nw.js v0.12.0.
File: AwesomeGuildStore01/29/19
Hello, when can I expect the new...
Posted By: sirinsidiator
Hello, when can I expect the new patch please? Ty, Evs I just uploaded it.
File: AwesomeGuildStore01/27/19
this will be fixed in new patch i g...
Posted By: sirinsidiator
this will be fixed in new patch i guess:banana: Exactly.
File: sidWarTools01/27/19
I'll give it a small update once I...
Posted By: sirinsidiator
I'll give it a small update once I finished AGSv1.0.
File: sidTools01/27/19
item viewer is outdated? i cant fi...
Posted By: sirinsidiator
item viewer is outdated? i cant find any new motifs or sets i believe post-summerset Yeah, but since this is a developer tool, it doesn't have any priority. Addon developers can easily overcome the issue on their own if they need to. I suggest you use one of the many regular addons that can show items or motifs. ;)
File: AwesomeGuildStore01/23/19
@manwoodsal thanks for reporting it...
Posted By: sirinsidiator
@manwoodsal thanks for reporting it. The current version of AGS will no longer be usable once the Wrathstone update goes live due to the massive changes to the trading house. In order to avoid confusion I plan to push a small update next week, which will show a popup when visiting the store and prevent AGS from running any code that...
File: AwesomeGuildStore01/19/19
There is no need to worry. I have b...
Posted By: sirinsidiator
There is no need to worry. I have been in contact with ZOS about changes to the store API over the past year and been preparing for this moment ever since. Since the Khajiit is out of the bag, here are some highlights you can expect in AwesomeGuildStore v1.0 (you read that right, it will finally be out of beta! :D ). Result c...
File: AwesomeGuildStore01/16/19
There is no need to worry. I have b...
Posted By: sirinsidiator
There is no need to worry. I have been in contact with ZOS about changes to the store API over the past year and been preparing for this moment ever since. Since the Khajiit is out of the bag, here are some highlights you can expect in AwesomeGuildStore v1.0 (you read that right, it will finally be out of beta! :D ). Result c...
File: AwesomeGuildStore01/16/19
There is no need to worry. I have b...
Posted By: sirinsidiator
There is no need to worry. I have been in contact with ZOS about changes to the store API over the past year and been preparing for this moment ever since. Since the Khajiit is out of the bag, here are some highlights you can expect in AwesomeGuildStore v1.0 (you read that right, it will finally be out of beta! :D ). Result c...
File: LibStub11/03/18
Re: Creating a library without LibStub
Posted By: sirinsidiator
Addon Authors: LibStub is no longer needed if you plan to write a new library. This confuses me a bit. How would I do this. I just declare my own global table and hope I gave it a unique-enough name? I thought the main purpose of LibStub was to take all those table references and stuff them into one big Global table named Lib...
File: LibStub11/03/18
Is this lib even necessary anymore?...
Posted By: sirinsidiator
Is this lib even necessary anymore? It hasn't been updated since 2014. I'd like to delete it. Yes, very much so. If you remove it, almost every single library you have will not work. Is this still the case, seeing as the add-on description reads "LibStub is no longer needed if you plan to write a new library" at the top. This...
File: EasyTravel10/30/18
Requesting feature to disable (cert...
Posted By: sirinsidiator
Requesting feature to disable (certain) players from being targeted by the teleports. At the very least those on 'ignored' list. Right now some random dude from trading guild with 'vv' in his id is overriding my /tp vv commands and it makes the game literally unplayable. :mad: I'm sorry to hear that your game has become unplayabl...
File: AwesomeGuildStore10/30/18
i found "ClearCursor()" in this add...
Posted By: sirinsidiator
i found "ClearCursor()" in this addon, so MAY BE it responsible for issue number 2 from this topic of bugs https://www.esoui.com/forums/showthread.php?t=8132 No.
File: AwesomeGuildStore10/27/18
I am getting the same error. I am n...
Posted By: sirinsidiator
I am getting the same error. I am not using Minion. Is it the exact same error with the same lines? If so, does it happen again after you extract the files from the same downloaded archive again? In that case, could you please upload that archive so I can check if it looks different to the original one that I uploaded to esoui? h...
File: AwesomeGuildStore10/27/18
I am getting the same error. I am n...
Posted By: sirinsidiator
I am getting the same error. I am not using Minion. Is it the exact same error with the same lines? If so, does it happen again after you extract the files from the same downloaded archive again? In that case, could you please upload that archive so I can check if it looks different to the original one that I uploaded to esoui?
File: AwesomeGuildStore10/24/18
Still getting this error: user:/...
Posted By: sirinsidiator
Still getting this error: user:/AddOns/AwesomeGuildStore/searchfilters/CategorySelector.lua:198: attempt to index a nil value stack traceback: user:/AddOns/AwesomeGuildStore/searchfilters/CategorySelector.lua:198: in function 'ShowGuildSpecificItems' user:/AddOns/AwesomeGuildStore/searchfilters/CategorySelector.lua:210: in func...
File: AwesomeGuildStore10/24/18
It would actually be enough to remo...
Posted By: sirinsidiator
It would actually be enough to remove all LibCustomMenu folders that contain a version older than ~6.3. Meaning that it won't be an issue since those old addons won't get an update OR if they do, they should contain the new version 6.6.2. It also means that you could just delete the Lib in all addons except AGS, since I bundled the n...
File: AwesomeGuildStore10/23/18
It seems there is a problem with lo...
Posted By: sirinsidiator
It seems there is a problem with loading LibCustomMenu when there is an older version anywhere in your addons folder. Try to delete all LibCustomMenu folders and install it again via Minion. That should fix the craftbag issue. I found the LibCustomMenu folder and deleted it. Then I uninstalled the addon via Minion and reinstalled,...
File: AwesomeGuildStore10/23/18
I updated this morning using Minion...
Posted By: sirinsidiator
I updated this morning using Minion and am getting the following UI Error in game. assertion failed stack traceback: : in function 'assert' user:/AddOns/AwesomeGuildStore/StartUp.lua:168: in function 'IntegrityCheck' user:/AddOns/AwesomeGuildStore/StartUp.lua:229: in function 'callback' user:/AddOns/AwesomeGuildStore/StartUp....
File: AwesomeGuildStore10/23/18
It seems there is a problem with lo...
Posted By: sirinsidiator
It seems there is a problem with loading LibCustomMenu when there is an older version anywhere in your addons folder. Try to delete all LibCustomMenu folders and install it again via Minion. That should fix the craftbag issue.
File: AwesomeGuildStore10/22/18
@jizlerq I just uploaded a new vers...
Posted By: sirinsidiator
@jizlerq I just uploaded a new version which contains the latest LibGPS. The error should go away with it. @Phinix My theory is that when a user presses download while the new version is still pending, the old file is downloaded, but minion thinks it is the latest version and marks it as up to date. Meaning you have an outdated ad...