Quantcast Game crashing when installing addons - ESOUI
Thread Tools Display Modes
04/05/16, 04:23 PM   #1
Philos95
Join Date: Apr 2016
Posts: 5
Game crashing when installing addons

Hello,

I'm playing since january, using Minion to install a few addons and everything went well until the last DLC.

Since the Thieves Guild DLC, I'm in trouble with my game. 80% of the time I'm trying to log to the game, my character appears in game and after 2 seconds I'm back to the login page. And it appears mostly after installing and/or activating addons.

I got in touch with the TESO support, and after a few various solutions, the tech guy said "do a new install and do not use addons anymore"...

I did try a lot of reparation, and even a new installation. It does not change anything.

Sometimes I can log in correctly, but as soon as I install an addon, even not activated, the game is crashing. Then, I delete every addon and the SavedVariables repertory, but I can not get back to the game for hours... sometimes I can play with one or two addons, but if I install a third one, the game is crashing... and then even if I clean up everything it's not working anymore for a long time...

My brother did try to play with my character from his home, and could play with a lot of addons installed and activated with NO problem...

Any idea or suggestion is welcome.

Thanks
  Reply With Quote
04/06/16, 01:56 AM   #2
QuadroTony
Banned
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 828
its not an addon

obviously, if your brother can play

try to change ISP, or maybe try to use VPN
its smthing with your connection
  Reply With Quote
04/06/16, 08:14 AM   #3
Philos95
Join Date: Apr 2016
Posts: 5
Thanks you QuadroTony,

I have already tried a few things with my connection, like forwarding the ports, doing a /ipconfig flushdns, giving my computer a local static IP.

I can not change my ISP so easily

I will give a try to the VPN.

If it is something with the connection, what could make my game crash for hours, it is like after a crash it takes 2 or 3 hours for me to connect to the game again, and during that time, everytime I try, I go back to the login screen.

Thanks anyway.
  Reply With Quote
04/06/16, 08:21 AM   #4
QuadroTony
Banned
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 828
or this thing
almost the same as VPN

https://www.wtfast.com/
  Reply With Quote
04/06/16, 09:38 AM   #5
Philos95
Join Date: Apr 2016
Posts: 5
Thanks again QuadroTony.

I have a doubt about the connection, I just installed the game on my wife's laptop. I can log all my characters with lot of addons and no problem. I did a lot of tests and everything is fine.

On my computer it is not the same story... I think the problem is from my desktop.

I have started a clean installation, after cleaning the windows registry and deleting everything from ESO, everywhere!

I will keep you posted.
  Reply With Quote
04/06/16, 10:19 AM   #6
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,626
I only crash back to the login screen if I'm idle for too long time, or if login takes too much time.
Login time depends on activated addons and their SavedVariables somehow, especially data mining addons like HarvestMap or Inventory saving addons like MasterMerchant, GuildStore addons, InventoryInsight, MobileBank etc. take some time to load the data from the SavedVariables file.

If you disable all addons and the login will take short, you're ingame and crash back to the desktop or the login screen it might have not do with any addons but your internet connection and used proxy servers etc.

Logout, close the client and launcher.
Search for the following files and rename them or move them to other folders (backup):

C:\users\<your windows username>\document\Elder Scolls Online\SavedVariables\zos*.lua
-> * is a placeholder for any name, so just find all zos....lua filenames like zos_ingame.lua etc.

C:\users\<your windows username>\document\Elder Scolls Online\ShaderCache.cooked (or something similar)

And try to rename the following filename so your used addons are not saved, and you need to enable/disable them all again at the game's ingame addon list:
C:\users\<your windows username>\document\Elder Scolls Online\AddonPreferences.txt (or the similar name)

On the first login please disable all addons and just tyr if this works well.
Then enable each addon after another and check which one is cuasing a dump to the login screen again.
For this addon try to rename the SavedVariables filename so it won't be loaded anymore, and see if this helps!
  Reply With Quote
04/06/16, 10:50 AM   #7
Philos95
Join Date: Apr 2016
Posts: 5
Thanks for the support Baertram,

I already did everything you are suggesting. It is now 3 weeks I'm experiencing problems, so I did try a lot of solutions.

But, as I did mention just before, there is no problem with my wife's computer, so I think the connection is not the problem.

And for the others things to do, I did all that at least 10 times, even a new installation.

Thanks anyway.
  Reply With Quote
04/06/16, 10:56 AM   #8
Ayantir
 
Ayantir's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2014
Posts: 1,022
Comme je te l'ai indiqué sur JOL, tu te trompe d'endroit.
Les addons ne sont pas le problème.
__________________
Obsessive Compulsive Coder

My little french Guild: Cercle de l'Eveil
  Reply With Quote
04/06/16, 11:01 AM   #9
sirinsidiator
 
sirinsidiator's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 1,315
It may very well be unrelated to the game itself and be a hardware issue with your PC.
Try to run memtest86 and see if there is a problem with your RAM. That could be one reason why it crashes.
You may also want to try prime95 and FurMark to see if your PC runs stable.
__________________
Like what I do? Support me on Patreon!
>siri.exe MyAddon
Does your addon work? [y/n] n
There is a typo in there.
  Reply With Quote
04/07/16, 04:54 PM   #10
Philos95
Join Date: Apr 2016
Posts: 5
Ayandir, je sais maintenant que ce n'est pas lié à un addon, mais je sais aussi maintenant avec certitude que je parviens à me connecter sans addons mais qu'en installant (sans activation) ne serait-ce qu'un addon, le jeu plante, peu importe lequel.

Donc pas la faute d'un addon, mais dépendant de l'installation d'addons... et ça c'est sans hésitation, dans 100% des cas ça plante. Il y a un rapport avec les plantages et la présence d'addons et des fichiers liés.

Thanks Sirinsidiator, but the RAM looks fine and the stress test from FurMark is ok.

As I say to Ayandir, I'm sure the problem does not come from an addon in particular, but I also know that everytime I install one, the game crashes after not more than 2 seconds after I enter the game. Everytime!
  Reply With Quote
04/08/16, 05:33 AM   #11
votan
 
votan's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2014
Posts: 502
Originally Posted by Philos95 View Post
Ayandir, je sais maintenant que ce n'est pas lié à un addon, mais je sais aussi maintenant avec certitude que je parviens à me connecter sans addons mais qu'en installant (sans activation) ne serait-ce qu'un addon, le jeu plante, peu importe lequel.

Donc pas la faute d'un addon, mais dépendant de l'installation d'addons... et ça c'est sans hésitation, dans 100% des cas ça plante. Il y a un rapport avec les plantages et la présence d'addons et des fichiers liés.

Thanks Sirinsidiator, but the RAM looks fine and the stress test from FurMark is ok.

As I say to Ayandir, I'm sure the problem does not come from an addon in particular, but I also know that everytime I install one, the game crashes after not more than 2 seconds after I enter the game. Everytime!
Although I don't have a solution, I just want to mention, that a crash after a few seconds of freeze is a typical sign of a stack overflow due to infinitive recursion. While an endless freeze (loading screen) could come from a never ending Lua loop.
In both cases, the author of the addon would not release that addon. Which typically leads to "unexpected data".
I know some regular expressions can crash on UTF-8 encoded strings (non english characters). (because Lua is ANSI)
@Philos95: Any idea what this could be in your case? Your avatar name?!?

/edit: Ok, your brother could play. So, it is not your avatar's name. Which addons we are talking about?
__________________
@votan73 (EU - megaserver)

Last edited by votan : 04/08/16 at 05:47 AM.
  Reply With Quote
04/08/16, 07:09 AM   #12
Ayantir
 
Ayantir's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2014
Posts: 1,022
Take care,

An infinite loop crash the game after few seconds and show the bug report. Same for savedvars > 4GB. Sometimes, it's the Windows "ESO stopped running" but the executable crash.

Here our user is sent back to login screen. Except MM which did this (and there was the popup "Unknown error") long time ago, i don't remember any addon doing this.
__________________
Obsessive Compulsive Coder

My little french Guild: Cercle de l'Eveil
  Reply With Quote
04/08/16, 07:52 AM   #13
Baertram
 
Baertram's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2014
Posts: 2,626
I got this "send back to login screen" as well sometimes in the past weeks, after the TG update!
All of sudden, mainly if I was doing nothing at this moment, I got back to the login screen without any message (so it was not a time out as I get a message shown in these cases).

Sometimes it happens from ingame as I'm playing and running around.
Sometimes it happens after I was logging in, selected my character, and then try to play -> After a few seconds I'm back at the login screen.

I think it is some internal problem of the game + network connection in the most cases as it behaves exactly the same as if my ISP disconnected me after 24h.
  Reply With Quote
04/08/16, 08:42 AM   #14
QuadroTony
Banned
AddOn Author - Click to view addons
Join Date: Apr 2014
Posts: 828
sometime ago i though when you was kicked out to login screen - it was because the GM entering to your account for review or smthing
but now i am not sure
  Reply With Quote
04/08/16, 08:55 AM   #15
Ayantir
 
Ayantir's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2014
Posts: 1,022
Since TG, a lot of people are experiencing this "revert to login screen", that's only a game failure between gameserver and another one (login one, db one).

I personally got it once a week, some more serious gamer got it once 2/3 days. that's a little zos issue.
__________________
Obsessive Compulsive Coder

My little french Guild: Cercle de l'Eveil
  Reply With Quote

ESOUI » General Discussion » Tech Chat » Game crashing when installing addons

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off